Avatar upload problem

Thread Started By helbelle666

968
5
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Rate Thread
#1
So, I'm trying to make an avatar in blender that uses the appearance sliders (That's a fitted avatar, right?  I don't know if I have the terminology right).  I've weight painted it, and it works perfectly in blender.  When I export to second life, it PHYSICALLY works fine, but no skins will work with it.  it's just a white body.  I was told to upload "materials" instead of "Textures" and I did that, but the result is the same.  One thing I did notice is that the UV map got messed up when I symmetrized the mesh.  The avatar moves fine, and the shape edits and behaves as it should.  I just can't apply textures to it.  I asked the creator of the skin I'm using for help, and they said that when they uploaded it with materials instead of textures, it worked right, but it doesn't for me.  What am I doing wrong?  I can't find any answers to this in any forums or youtube videos.  I've even followed along exactly with multiple tutorials, and the creators don't have this problem.  Please help.  I'm happy to elaborate, or even provide pictures if that would help explain better.  Thank you in advance for any guidance you have.

Hel
Reply


#2
Your avatar needs to be unwrapped properly,else it'll not take textures correctly.Check the UV/Image editor and see.Also use texture render mode in blender and check how textures look on it(pbr don't work in sl so if using those you'll get broken textures).If you tried symmetrizing the mesh,it makes SL UVs screwed.If you using sl body in avastar,then no need to symmertize,or mess with UVs or weight paint,just change sliders,sculpt a bit,and export.
Reply


#3
(12-18-2021, 09:35 AM)Necrok Wrote:

[To see links please register here]

Your avatar needs to be unwrapped properly,else it'll not take textures correctly.Check the UV/Image editor and see.Also use texture render mode in blender and check how textures look on it(pbr don't work in sl so if using those you'll get broken textures).If you tried symmetrizing the mesh,it makes SL UVs screwed.If you using sl body in avastar,then no need to symmertize,or mess with UVs or weight paint,just change sliders,sculpt a bit,and export.
Thank you for responding!

I'm using Avastar, but not an avastar body.  I symmetrized the mesh, yes, and it did screw up the UV map.  I did it to avoid having to weight paint both sides separately because I didn't think I could do it evenly.  I also have no idea how to sculpt yet, at least not to the level of detail that this model has.

Are you saying that I either need to weight paint the sides individually, or learn to sculpt accurate musculature?  Just trying to understand.  Is there no way to repair the UV map after it's messed up from symmetrize?  I've tried selecting all and unwrapping, and it just makes a weird circle of meshes.  Right now both the upper and lower body UVs are on one map, but they are, like you said, jacked up from symmetrize.
Reply


#4
(12-18-2021, 09:35 AM)Necrok Wrote:

[To see links please register here]

Your avatar needs to be unwrapped properly,else it'll not take textures correctly.Check the UV/Image editor and see.Also use texture render mode in blender and check how textures look on it(pbr don't work in sl so if using those you'll get broken textures).If you tried symmetrizing the mesh,it makes SL UVs screwed.If you using sl body in avastar,then no need to symmertize,or mess with UVs or weight paint,just change sliders,sculpt a bit,and export.

Okay, so.  I went back to before I symmetrized the mesh.  I have a complete UV map now, and I copied all the materials and textures directly from the avamesh to the fitted mesh.  In texture render mode, the textures don't show up, and my mesh is all white.  Suggestions?  Thank you for the advice you already gave.
Reply


#5
bom dia,tente fazer  a transferencia de uv maps,peque um modelo parecido  que tenha uv para fazer as transferencias ou recorte usando Edge Select e nao o Vertex Select.

(Lagertha i translate) 
Good day, try to transfer uv maps, a small similar model that has uv to make transfers or clipping using Edge Select or Vertex Select.
Reply


#6
(01-02-2022, 07:31 AM)erenio Wrote:

[To see links please register here]

bom dia,tente fazer  a transferencia de uv maps,peque um modelo parecido  que tenha uv para fazer as transferencias ou recorte usando Edge Select e nao o Vertex Select.

(Lagertha i translate) 
Good day, try to transfer uv maps, a small similar model that has uv to make transfers or clipping using Edge Select or Vertex Select.
Thank you I'll try this.
Reply




Possibly Related Threads…
Thread Author Replies Views Last Post
Lightbulb Email problem during account creation Saeki Amae 7 421 08-14-2022, 02:18 PM
Last Post: Lagertha
  Weird face issue during upload Saeki Amae 2 201 08-14-2022, 01:36 AM
Last Post: Saeki Amae
Star Hydrastorm AO problem Saeki Amae 9 761 06-30-2022, 12:29 PM
Last Post: Lagertha
  Upload Error fe23pza 4 1,240 09-17-2020, 11:40 AM
Last Post: witchy
  add attach problem yorkshiregirl 2 1,319 05-04-2020, 04:12 AM
Last Post: yorkshiregirl
  AVASTAR problem alrahil 1 1,898 11-07-2018, 09:03 AM
Last Post: tyla
  Meshes upload issue kiki00 1 2,610 02-26-2018, 09:36 AM
Last Post: kika
  Problem Exporting Mesh to OpenSim SebringTech 8 9,101 11-29-2016, 06:53 AM
Last Post: fridaynight
  Transfer Weights Problem shameronc 1 2,871 09-12-2016, 07:29 AM
Last Post: Lolo
  True you can bypass upload fees? OnyxAmethyst 0 2,131 06-04-2016, 02:52 AM
Last Post: OnyxAmethyst

Forum Jump:

1 Guest(s)
Share this:

About Second Life Copybot

Second Life CopyBot Forum is a place where you can get items for Second Life and other vitual worlds for free. With our CopyBot viewers you can export and import any content from these virtual worlds and modify them in 3D software such as Blender, 3D studio Macx etc...